Kies je gewenste PHP versie in Plesk

Sinds Plesk 12+ is het mogelijk meerdere PHP-versies naast elkaar te draaien. Hierdoor kunt u dus per website kiezen welke PHP-versie u wenst!

Wij bieden de volgende versies:

  • PHP 7.2
  • PHP 7.1
  • PHP 7.0
  • PHP 5.6
  • PHP 5.5
  • PHP 5.4
  • PHP 5.3

Wisselen van PHP-versie

Log in op het Plesk controlpanel van uw server. Scroll naar het domein dat u van PHP-versie wenst te wisselen, en klik op "Hosting Settings".

Iets naar onderen op de pagina vindt u de optie "PHP support (PHP version ..., run PHP as ...).

 

Kies in het pulldownmenu voor de door u gewenste versie en klik op "OK". Wanneer de webserver herstart (dit kan tot 3 uur duren), zal van versie gewisseld worden.

Wanneer u direct wenst te testen of uw website onder de genoemde versie draait, of snel wilt terugschakelen, raden wij aan om dit tijdens kantooruren te doen en contact op te nemen om de webserver direct te laten herstarten.

Bij "Run PHP as" is te kiezen tussen PHP-FPM, FastCGI en mod_php. Niet alle opties zullen beschikbaar zijn per versie. Indien beschikbaar raden wij PHP-FPM aan.

Voordelen nieuwere PHP-versies

Het kiezen van een nieuwere PHP-versie heeft diverse voordelen. Naast dat er nieuwe functionaliteit bij is gekomen, is er echter ook functionaliteit verdwenen of gewijzigd. Het is daarom raadzaam om uw website goed te testen om te zien of deze wel compatibel is met nieuwere versies.

Wij hebben diverse benchmark-tests losgelaten op de snelheid van uitvoeren van scripts in PHP in de verschillende versies. Hieruit komen de volgende veranderingen:

PHP 7.2 heeft ten opzich van PHP 7.1 een snelheidswinst van ongeveer 16%

PHP 7.1 heeft ten opzichte van PHP 7.0, een snelheidswinst van ongeveer 28%

PHP 7.0 heeft ten opzichte van PHP 5.6 een snelheidswinst van ongeveer 57%.

PHP 5.6 heeft ten opzichte van PHP 5.5 een snelheidswinst van ongeveer 5%

PHP 5.5 heeft ten opzichte van PHP 5.4 een snelheidswinst van ongeveer 3,5%

PHP 5.4 heeft ten opzichte van PHP 5.3 een snelheidswinst van ongeveer 40%

Zo ziet u: Hoe nieuwer de PHP-versie, des te meer snelheid uw website zal hebben.

Daarnaast zijn PHP-versies ouder dan 5.6 niet meer ondersteund in de vorm van security updates, wat betekent dat gevonden fouten niet meer opgelost zullen worden. U loopt hierdoor risico. Wij raden daarom aan minimaal PHP 5.6 te draaien, deze zal pas na 1 januari 2019 geen security updates meer krijgen.

Onderwerpen

Gerelateerd

Categorie

Delen





 

Komt u er ondanks deze hulppagina's niet uit? Uiteraard staan wij klaar om u verder te helpen!